forked from ankitggits/SplunkJavaLogging
-
Notifications
You must be signed in to change notification settings - Fork 0
Expand file tree
/
Copy pathSplunkLogEvent.java
More file actions
2396 lines (2097 loc) · 74.7 KB
/
SplunkLogEvent.java
File metadata and controls
2396 lines (2097 loc) · 74.7 KB
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
296
297
298
299
300
301
302
303
304
305
306
307
308
309
310
311
312
313
314
315
316
317
318
319
320
321
322
323
324
325
326
327
328
329
330
331
332
333
334
335
336
337
338
339
340
341
342
343
344
345
346
347
348
349
350
351
352
353
354
355
356
357
358
359
360
361
362
363
364
365
366
367
368
369
370
371
372
373
374
375
376
377
378
379
380
381
382
383
384
385
386
387
388
389
390
391
392
393
394
395
396
397
398
399
400
401
402
403
404
405
406
407
408
409
410
411
412
413
414
415
416
417
418
419
420
421
422
423
424
425
426
427
428
429
430
431
432
433
434
435
436
437
438
439
440
441
442
443
444
445
446
447
448
449
450
451
452
453
454
455
456
457
458
459
460
461
462
463
464
465
466
467
468
469
470
471
472
473
474
475
476
477
478
479
480
481
482
483
484
485
486
487
488
489
490
491
492
493
494
495
496
497
498
499
500
501
502
503
504
505
506
507
508
509
510
511
512
513
514
515
516
517
518
519
520
521
522
523
524
525
526
527
528
529
530
531
532
533
534
535
536
537
538
539
540
541
542
543
544
545
546
547
548
549
550
551
552
553
554
555
556
557
558
559
560
561
562
563
564
565
566
567
568
569
570
571
572
573
574
575
576
577
578
579
580
581
582
583
584
585
586
587
588
589
590
591
592
593
594
595
596
597
598
599
600
601
602
603
604
605
606
607
608
609
610
611
612
613
614
615
616
617
618
619
620
621
622
623
624
625
626
627
628
629
630
631
632
633
634
635
636
637
638
639
640
641
642
643
644
645
646
647
648
649
650
651
652
653
654
655
656
657
658
659
660
661
662
663
664
665
666
667
668
669
670
671
672
673
674
675
676
677
678
679
680
681
682
683
684
685
686
687
688
689
690
691
692
693
694
695
696
697
698
699
700
701
702
703
704
705
706
707
708
709
710
711
712
713
714
715
716
717
718
719
720
721
722
723
724
725
726
727
728
729
730
731
732
733
734
735
736
737
738
739
740
741
742
743
744
745
746
747
748
749
750
751
752
753
754
755
756
757
758
759
760
761
762
763
764
765
766
767
768
769
770
771
772
773
774
775
776
777
778
779
780
781
782
783
784
785
786
787
788
789
790
791
792
793
794
795
796
797
798
799
800
801
802
803
804
805
806
807
808
809
810
811
812
813
814
815
816
817
818
819
820
821
822
823
824
825
826
827
828
829
830
831
832
833
834
835
836
837
838
839
840
841
842
843
844
845
846
847
848
849
850
851
852
853
854
855
856
857
858
859
860
861
862
863
864
865
866
867
868
869
870
871
872
873
874
875
876
877
878
879
880
881
882
883
884
885
886
887
888
889
890
891
892
893
894
895
896
897
898
899
900
901
902
903
904
905
906
907
908
909
910
911
912
913
914
915
916
917
918
919
920
921
922
923
924
925
926
927
928
929
930
931
932
933
934
935
936
937
938
939
940
941
942
943
944
945
946
947
948
949
950
951
952
953
954
955
956
957
958
959
960
961
962
963
964
965
966
967
968
969
970
971
972
973
974
975
976
977
978
979
980
981
982
983
984
985
986
987
988
989
990
991
992
993
994
995
996
997
998
999
1000
package com.splunk.logging;
import java.util.Date;
import org.apache.commons.lang.time.FastDateFormat;
/**
* <pre>
* This is a class to encapsulate a Splunk Log Event Message using Splunk best practice logging semantics.
* It is based on standard Splunk CIM(Common Information Model) fields.
* You can also add any of your own custom fields as you require.
* <br/>
* You will most likely use this class to format a message to pass to your logging framework (log4j, java.util logging, logback etc..).
*
* <code>
* Logger logger = LoggerFactory.getLogger("splunk.logger");
* SplunkLogEvent event = new SplunkLogEvent("Failed Login","sshd:failure");
* event.setAuthApp("jane");
* event.setAuthUser("jane");
* event.addPair("somefieldname", "foobar");
* logger.info(event.toString());
* </code>
*
* The underlying log framework will also have a grammar for declaring a log message pattern.
* Therefore you can either just log the SplunkLogEvent string as is, or augment it with other log pattern pattern variables when configuring your logger appenders/handlers.
*
* </pre>
*
* @see <a
* href="http://docs.splunk.com/Documentation/Splunk/latest/Knowledge/UnderstandandusetheCommonInformationModel">Splunk
* CIM</a>
* @see <a
* href="http://dev.splunk.com/view/logging-best-practices/SP-CAAADP6">Splunk
* Logging Best Practices</a>
*
*
* @author Damien Dallimore damien@dtdsoftware.com
*
*/
public class SplunkLogEvent {
/**
* Contents of the event message
*/
private StringBuffer eventMessage;
/**
* Whether or not to put quotes around values
*/
private boolean quoteValues = true;
/**
* Whether or not to add a date to the event string
*/
private boolean useInternalDate = true;
/**
* default key value delimiter
*/
private static final String KVDELIM = "=";
/**
* default pair delimiter
*/
private static final String PAIRDELIM = " ";
/**
* default quote char
*/
private static final char QUOTE = '"';
/**
* default date format is using internal generated date
*/
private static final String DATEFORMATPATTERN = "yyyy-MM-dd HH:mm:ss:SSSZ";
/**
* Date Formatter instance
*/
private static FastDateFormat DATEFORMATTER = FastDateFormat
.getInstance(DATEFORMATPATTERN);
/**
* Event prefix fields
*/
private static final String PREFIX_NAME = "name";
private static final String PREFIX_EVENT_ID = "event_id";
/**
* Java Throwable type fields
*/
private static final String THROWABLE_CLASS = "throwable_class";
private static final String THROWABLE_MESSAGE = "throwable_message";
private static final String THROWABLE_STACKTRACE_ELEMENTS = "stacktrace_elements";
/**
* Splunk Common Information Model(CIM) Fields
*/
// ------------------
// Account management
// ------------------
/**
* The domain containing the user that is affected by the account management
* event.
*/
public static String AC_MANAGEMENT_DEST_NT_DOMAIN = "dest_nt_domain";
/**
* Description of the account management change performed.
*/
public static String AC_MANAGEMENT_SIGNATURE = "signature";
/**
* The NT source of the destination. In the case of an account management
* event, this is the domain that contains the user that generated the
* event.
*/
public static String AC_MANAGEMENT_SRC_NT_DOMAIN = "src_nt_domain";
// ----------------------------------
// Authentication - Access protection
// ----------------------------------
/**
* The action performed on the resource. success, failure
*/
public static String AUTH_ACTION = "action";
/**
* The application involved in the event (such as ssh, spunk, win:local).
*/
public static String AUTH_APP = "app";
/**
* The target involved in the authentication. If your field is named
* dest_host, dest_ip, dest_ipv6, or dest_nt_host you can alias it as dest
* to make it CIM-compliant.
*/
public static String AUTH_DEST = "dest";
/**
* The source involved in the authentication. In the case of endpoint
* protection authentication the src is the client. If your field is named
* src_host, src_ip, src_ipv6, or src_nt_host you can alias it as src to
* make it CIM-compliant.. It is required for all events dealing with
* endpoint protection (Authentication, change analysis, malware, system
* center, and update). Note: Do not confuse this with the event source or
* sourcetype fields.
*/
public static String AUTH_SRC = "src";
/**
* In privilege escalation events, src_user represents the user who
* initiated the privilege escalation.
*/
public static String AUTH_SRC_USER = "src_user";
/**
* The name of the user involved in the event, or who initiated the event.
* For authentication privilege escalation events this should represent the
* user targeted by the escalation.
*/
public static String AUTH_USER = "user";
// ----------------------------------
// Change analysis - Endpoint protection
// ----------------------------------
/**
* The action performed on the resource.
*/
public static String CHANGE_ENDPOINT_PROTECTION_ACTION = "action";
/**
* The type of change discovered in the change analysis event.
*/
public static String CHANGE_ENDPOINT_PROTECTION_CHANGE_TYPE = "change_type";
/**
* The host that was affected by the change. If your field is named
* dest_host,dest_ip,dest_ipv6, or dest_nt_host you can alias it as dest to
* make it CIM-compliant.
*/
public static String CHANGE_ENDPOINT_PROTECTION_DEST = "dest";
/**
* The hash signature of the modified resource.
*/
public static String CHANGE_ENDPOINT_PROTECTION_HASH = "hash";
/**
* The group ID of the modified resource.
*/
public static String CHANGE_ENDPOINT_PROTECTION_GID = "gid";
/**
* Indicates whether or not the modified resource is a directory.
*/
public static String CHANGE_ENDPOINT_PROTECTION_ISDR = "isdr";
/**
* The permissions mode of the modified resource.
*/
public static String CHANGE_ENDPOINT_PROTECTION_MODE = "mode";
/**
* The modification time of the modified resource.
*/
public static String CHANGE_ENDPOINT_PROTECTION_MODTIME = "modtime";
/**
* The file path of the modified resource.
*/
public static String CHANGE_ENDPOINT_PROTECTION_PATH = "path";
/**
* The size of the modified resource.
*/
public static String CHANGE_ENDPOINT_PROTECTION_SIZE = "size";
/**
* The user ID of the modified resource.
*/
public static String CHANGE_ENDPOINT_PROTECTION_UID = "uid";
// ----------------------------------
// Change analysis - Network protection
// ----------------------------------
/**
* The type of change observed.
*/
public static String CHANGE_NETWORK_PROTECTION_ACTION = "action";
/**
* The command that initiated the change.
*/
public static String CHANGE_NETWORK_PROTECTION_COMMAND = "command";
/**
* The device that is directly affected by the change.
*/
public static String CHANGE_NETWORK_PROTECTION_DVC = "dvc";
/**
* The user that initiated the change.
*/
public static String CHANGE_NETWORK_PROTECTION_USER = "user";
// ----------------------------------
// Common event fields
// ----------------------------------
/**
* A device-specific classification provided as part of the event.
*/
public static String COMMON_CATEGORY = "category";
/**
* A device-specific classification provided as part of the event.
*/
public static String COMMON_COUNT = "count";
/**
* The free-form description of a particular event.
*/
public static String COMMON_DESC = "desc";
/**
* The name of a given DHCP pool on a DHCP server.
*/
public static String COMMON_DHCP_POOL = "dhcp_pool";
/**
* The amount of time the event lasted.
*/
public static String COMMON_DURATION = "duration";
/**
* The fully qualified domain name of the device transmitting or recording
* the log record.
*/
public static String COMMON_DVC_HOST = "dvc_host";
/**
* The IPv4 address of the device reporting the event.
*/
public static String COMMON_DVC_IP = "dvc_ip";
/**
* The IPv6 address of the device reporting the event.
*/
public static String COMMON_DVC_IP6 = "dvc_ip6";
/**
* The free-form description of the device's physical location.
*/
public static String COMMON_DVC_LOCATION = "dvc_location";
/**
* The MAC (layer 2) address of the device reporting the event.
*/
public static String COMMON_DVC_MAC = "dvc_mac";
/**
* The Windows NT domain of the device recording or transmitting the event.
*/
public static String COMMON_DVC_NT_DOMAIN = "dvc_nt_domain";
/**
* The Windows NT host name of the device recording or transmitting the
* event.
*/
public static String COMMON_DVC_NT_HOST = "dvc_nt_host";
/**
* Time at which the device recorded the event.
*/
public static String COMMON_DVC_TIME = "dvc_time";
/**
* The event's specified end time.
*/
public static String COMMON_END_TIME = "end_time";
/**
* A unique identifier that identifies the event. This is unique to the
* reporting device.
*/
public static String COMMON_EVENT_ID = "event_id";
/**
* The length of the datagram, event, message, or packet.
*/
public static String COMMON_LENGTH = "length";
/**
* The log-level that was set on the device and recorded in the event.
*/
public static String COMMON_LOG_LEVEL = "log_level";
/**
* The name of the event as reported by the device. The name should not
* contain information that's already being parsed into other fields from
* the event, such as IP addresses.
*/
public static String COMMON_NAME = "name";
/**
* An integer assigned by the device operating system to the process
* creating the record.
*/
public static String COMMON_PID = "pid";
/**
* An environment-specific assessment of the event's importance, based on
* elements such as event severity, business function of the affected
* system, or other locally defined variables.
*/
public static String COMMON_PRIORITY = "priority";
/**
* The product that generated the event.
*/
public static String COMMON_PRODUCT = "product";
/**
* The version of the product that generated the event.
*/
public static String COMMON_PRODUCT_VERSION = "product_version";
/**
* The result root cause, such as connection refused, timeout, crash, and so
* on.
*/
public static String COMMON_REASON = "reason";
/**
* The action result. Often is a binary choice: succeeded and failed,
* allowed and denied, and so on.
*/
public static String COMMON_RESULT = "result";
/**
* The severity (or priority) of an event as reported by the originating
* device.
*/
public static String COMMON_SEVERITY = "severity";
/**
* The event's specified start time.
*/
public static String COMMON_START_TIME = "start_time";
/**
* The transaction identifier.
*/
public static String COMMON_TRANSACTION_ID = "transaction_id";
/**
* A uniform record locator (a web address, in other words) included in a
* record.
*/
public static String COMMON_URL = "url";
/**
* The vendor who made the product that generated the event.
*/
public static String COMMON_VENDOR = "vendor";
// ----------------------------------
// DNS protocol
// ----------------------------------
/**
* The DNS domain that has been queried.
*/
public static String DNS_DEST_DOMAIN = "dest_domain";
/**
* The remote DNS resource record being acted upon.
*/
public static String DNS_DEST_RECORD = "dest_record";
/**
* The DNS zone that is being received by the slave as part of a zone
* transfer.
*/
public static String DNS_DEST_ZONE = "dest_zone";
/**
* The DNS resource record class.
*/
public static String DNS_RECORD_CLASS = "record_class";
/**
* The DNS resource record type.
*
* @see <a
* href="https://secure.wikimedia.org/wikipedia/en/wiki/List_of_DNS_record_types">see
* this Wikipedia article on DNS record types</a>
*/
public static String DNS_RECORD_TYPE = "record_type";
/**
* The local DNS domain that is being queried.
*/
public static String DNS_SRC_DOMAIN = "src_domain";
/**
* The local DNS resource record being acted upon.
*/
public static String DNS_SRC_RECORD = "src_record";
/**
* The DNS zone that is being transferred by the master as part of a zone
* transfer.
*/
public static String DNS_SRC_ZONE = "src_zone";
// ----------------------------------
// Email tracking
// ----------------------------------
/**
* The person to whom an email is sent.
*/
public static String EMAIL_RECIPIENT = "recipient";
/**
* The person responsible for sending an email.
*/
public static String EMAIL_SENDER = "sender";
/**
* The email subject line.
*/
public static String EMAIL_SUBJECT = "subject";
// ----------------------------------
// File management
// ----------------------------------
/**
* The time the file (the object of the event) was accessed.
*/
public static String FILE_ACCESS_TIME = "file_access_time";
/**
* The time the file (the object of the event) was created.
*/
public static String FILE_CREATE_TIME = "file_create_time";
/**
* A cryptographic identifier assigned to the file object affected by the
* event.
*/
public static String FILE_HASH = "file_hash";
/**
* The time the file (the object of the event) was altered.
*/
public static String FILE_MODIFY_TIME = "file_modify_time";
/**
* The name of the file that is the object of the event (without location
* information related to local file or directory structure).
*/
public static String FILE_NAME = "file_name";
/**
* The location of the file that is the object of the event, in terms of
* local file and directory structure.
*/
public static String FILE_PATH = "file_path";
/**
* Access controls associated with the file affected by the event.
*/
public static String FILE_PERMISSION = "file_permission";
/**
* The size of the file that is the object of the event. Indicate whether
* Bytes, KB, MB, GB.
*/
public static String FILE_SIZE = "file_size";
// ----------------------------------
// Intrusion detection
// ----------------------------------
/**
* The category of the triggered signature.
*/
public static String INTRUSION_DETECTION_CATEGORY = "category";
/**
* The destination of the attack detected by the intrusion detection system
* (IDS). If your field is named dest_host, dest_ip, dest_ipv6, or
* dest_nt_host you can alias it as dest to make it CIM-compliant.
*/
public static String INTRUSION_DETECTION_DEST = "dest";
/**
* The device that detected the intrusion event.
*/
public static String INTRUSION_DETECTION_DVC = "dvc";
/**
* The type of IDS that generated the event.
*/
public static String INTRUSION_DETECTION_IDS_TYPE = "ids_type";
/**
* The product name of the vendor technology generating network protection
* data, such as IDP, Providentia, and ASA.
*
* Note: Required for all events dealing with network protection (Change
* analysis, proxy, malware, intrusion detection, packet filtering, and
* vulnerability).
*/
public static String INTRUSION_DETECTION_PRODUCT = "product";
/**
* The severity of the network protection event (such as critical, high,
* medium, low, or informational).
*
* Note: This field is a string. Please use a severity_id field for severity
* ID fields that are integer data types.
*/
public static String INTRUSION_DETECTION_SEVERITY = "severity";
/**
* The name of the intrusion detected on the client (the src), such as
* PlugAndPlay_BO and JavaScript_Obfuscation_Fre.
*/
public static String INTRUSION_DETECTION_SIGNATURE = "signature";
/**
* The source involved in the attack detected by the IDS. If your field is
* named src_host, src_ip, src_ipv6, or src_nt_host you can alias it as src
* to make it CIM-compliant.
*/
public static String INTRUSION_DETECTION_SRC = "src";
/**
* The user involved with the intrusion detection event.
*/
public static String INTRUSION_DETECTION_USER = "user";
/**
* The vendor technology used to generate network protection data, such as
* IDP, Providentia, and ASA.
*
* Note: Required for all events dealing with network protection (Change
* analysis, proxy, malware, intrusion detection, packet filtering, and
* vulnerability).
*/
public static String INTRUSION_DETECTION_VENDOR = "vendor";
// ----------------------------------
// Malware - Endpoint protection
// ----------------------------------
/**
* The outcome of the infection
*/
public static String MALWARE_ENDPOINT_PROTECTION_ACTION = "action";
/**
* The NT domain of the destination (the dest_bestmatch).
*/
public static String MALWARE_ENDPOINT_PROTECTION_DEST_NT_DOMAIN = "dest_nt_domain";
/**
* The cryptographic hash of the file associated with the malware event
* (such as the malicious or infected file).
*/
public static String MALWARE_ENDPOINT_PROTECTION_FILE_HASH = "file_hash";
/**
* The name of the file involved in the malware event (such as the infected
* or malicious file).
*/
public static String MALWARE_ENDPOINT_PROTECTION_FILE_NAME = "file_name";
/**
* The path of the file involved in the malware event (such as the infected
* or malicious file).
*/
public static String MALWARE_ENDPOINT_PROTECTION_FILE_PATH = "file_path";
/**
* The product name of the vendor technology (the vendor field) that is
* generating malware data (such as Antivirus or EPO).
*/
public static String MALWARE_ENDPOINT_PROTECTION_PRODUCT = "product";
/**
* The product version number of the vendor technology installed on the
* client (such as 10.4.3 or 11.0.2).
*/
public static String MALWARE_ENDPOINT_PROTECTION_PRODUCT_VERSION = "product_version";
/**
* The name of the malware infection detected on the client (the src), such
* as Trojan.Vundo,Spyware.Gaobot,W32.Nimbda).
*
* Note: This field is a string. Please use a signature_id field for
* signature ID fields that are integer data types.
*/
public static String MALWARE_ENDPOINT_PROTECTION_SIGNATURE = "signature";
/**
* The current signature definition set running on the client, such as
* 11hsvx)
*/
public static String MALWARE_ENDPOINT_PROTECTION_SIGNATURE_VERSION = "signature_version";
/**
* The target affected or infected by the malware. If your field is named
* dest_host, dest_ip, dest_ipv6, or dest_nt_host you can alias it as dest
* to make it CIM-compliant.
*/
public static String MALWARE_ENDPOINT_PROTECTION_DEST = "dest";
/**
* The NT domain of the source (the src).
*/
public static String MALWARE_ENDPOINT_PROTECTION_SRC_NT_DOMAIN = "src_nt_domain";
/**
* The name of the user involved in the malware event.
*/
public static String MALWARE_ENDPOINT_PROTECTION_USER = "user";
/**
* The name of the vendor technology generating malware data, such as
* Symantec or McAfee.
*/
public static String MALWARE_ENDPOINT_PROTECTION_VENDOR = "vendor";
// ----------------------------------
// Malware - Network protection
// ----------------------------------
/**
* The product name of the vendor technology generating network protection
* data, such as IDP, Proventia, and ASA.
*
* Note: Required for all events dealing with network protection (Change
* analysis, proxy, malware, intrusion detection, packet filtering, and
* vulnerability).
*/
public static String MALWARE_NETWORK_PROTECTION_PRODUCT = "product";
/**
* The severity of the network protection event (such as critical, high,
* medium, low, or informational).
*
* Note: This field is a string. Please use a severity_id field for severity
* ID fields that are integer data types.
*/
public static String MALWARE_NETWORK_PROTECTION_SEVERITY = "severity";
/**
* The vendor technology used to generate network protection data, such as
* IDP, Proventia, and ASA.
*
* Note: Required for all events dealing with network protection (Change
* analysis, proxy, malware, intrusion detection, packet filtering, and
* vulnerability).
*/
public static String MALWARE_NETWORK_PROTECTION_VENDOR = "vendor";
// ----------------------------------
// Network traffic - ESS
// ----------------------------------
/**
* The action of the network traffic.
*/
public static String NETWORK_TRAFFIC_ESS_ACTION = "action";
/**
* The destination port of the network traffic.
*/
public static String NETWORK_TRAFFIC_ESS_DEST_PORT = "dest_port";
/**
* The product name of the vendor technology generating NetworkProtection
* data, such as IDP, Proventia, and ASA.
*
* Note: Required for all events dealing with network protection (Change
* analysis, proxy, malware, intrusion detection, packet filtering, and
* vulnerability).
*/
public static String NETWORK_TRAFFIC_ESS_PRODUCT = "product";
/**
* The source port of the network traffic.
*/
public static String NETWORK_TRAFFIC_ESS_SRC_PORT = "src_port";
/**
* The vendor technology used to generate NetworkProtection data, such as
* IDP, Proventia, and ASA.
*
* Note: Required for all events dealing with network protection (Change
* analysis, proxy, malware, intrusion detection, packet filtering, and
* vulnerability).
*/
public static String NETWORK_TRAFFIC_ESS_VENDOR = "vendor";
// ----------------------------------
// Network traffic - Generic
// ----------------------------------
/**
* The ISO layer 7 (application layer) protocol, such as HTTP, HTTPS, SSH,
* and IMAP.
*/
public static String NETWORK_TRAFFIC_GENERIC_APP_LAYER = "app_layer";
/**
* How many bytes this device/interface received.
*/
public static String NETWORK_TRAFFIC_GENERIC_BYTES_IN = "bytes_in";
/**
* How many bytes this device/interface transmitted.
*/
public static String NETWORK_TRAFFIC_GENERIC_BYTES_OUT = "bytes_out";
/**
* 802.11 channel number used by a wireless network.
*/
public static String NETWORK_TRAFFIC_GENERIC_CHANNEL = "channel";
/**
* The Common Vulnerabilities and Exposures (CVE) reference value.
*/
public static String NETWORK_TRAFFIC_GENERIC_CVE = "cve";
/**
* The destination application being targeted.
*/
public static String NETWORK_TRAFFIC_GENERIC_DEST_APP = "dest_app";
/**
* The destination command and control service channel.
*/
public static String NETWORK_TRAFFIC_GENERIC_DEST_CNC_CHANNEL = "dest_cnc_channel";
/**
* The destination command and control service name.
*/
public static String NETWORK_TRAFFIC_GENERIC_DEST_CNC_NAME = "dest_cnc_name";
/**
* The destination command and control service port.
*/
public static String NETWORK_TRAFFIC_GENERIC_DEST_CNC_PORT = "dest_cnc_port";
/**
* The country associated with a packet's recipient.
*/
public static String NETWORK_TRAFFIC_GENERIC_DEST_COUNTRY = "dest_country";
/**
* The fully qualified host name of a packet's recipient. For HTTP sessions,
* this is the host header.
*/
public static String NETWORK_TRAFFIC_GENERIC_DEST_HOST = "dest_host";
/**
* The interface that is listening remotely or receiving packets locally.
*/
public static String NETWORK_TRAFFIC_GENERIC_DEST_INT = "dest_int";
/**
* The IPv4 address of a packet's recipient.
*/
public static String NETWORK_TRAFFIC_GENERIC_DEST_IP = "dest_ip";
/**
* The IPv6 address of a packet's recipient.
*/
public static String NETWORK_TRAFFIC_GENERIC_DEST_IPV6 = "dest_ipv6";
/**
* The (physical) latitude of a packet's destination.
*/
public static String NETWORK_TRAFFIC_GENERIC_DEST_LAT = "dest_lat";
/**
* The (physical) longitude of a packet's destination.
*/
public static String NETWORK_TRAFFIC_GENERIC_DEST_LONG = "dest_long";
/**
* The destination TCP/IP layer 2 Media Access Control (MAC) address of a
* packet's destination.
*/
public static String NETWORK_TRAFFIC_GENERIC_DEST_MAC = "dest_mac";
/**
* The Windows NT domain containing a packet's destination.
*/
public static String NETWORK_TRAFFIC_GENERIC_DEST_NT_DOMAIN = "dest_nt_domain";
/**
* The Windows NT host name of a packet's destination.
*/
public static String NETWORK_TRAFFIC_GENERIC_DEST_NT_HOST = "dest_nt_host";
/**
* TCP/IP port to which a packet is being sent.
*/
public static String NETWORK_TRAFFIC_GENERIC_DEST_PORT = "dest_port";
/**
* The NATed IPv4 address to which a packet has been sent.
*/
public static String NETWORK_TRAFFIC_GENERIC_DEST_TRANSLATED_IP = "dest_translated_ip";
/**
* The NATed port to which a packet has been sent.
*/
public static String NETWORK_TRAFFIC_GENERIC_DEST_TRANSLATED_PORT = "dest_translated_port";
/**
* The numbered Internet Protocol version.
*/
public static String NETWORK_TRAFFIC_GENERIC_IP_VERSION = "ip_version";
/**
* The network interface through which a packet was transmitted.
*/
public static String NETWORK_TRAFFIC_GENERIC_OUTBOUND_INTERFACE = "outbound_interface";
/**
* How many packets this device/interface received.
*/
public static String NETWORK_TRAFFIC_GENERIC_PACKETS_IN = "packets_in";
/**
* How many packets this device/interface transmitted.
*/
public static String NETWORK_TRAFFIC_GENERIC_PACKETS_OUT = "packets_out";
/**
* The OSI layer 3 (Network Layer) protocol, such as IPv4/IPv6, ICMP, IPsec,
* IGMP or RIP.
*/
public static String NETWORK_TRAFFIC_GENERIC_PROTO = "proto";
/**
* The session identifier. Multiple transactions build a session.
*/
public static String NETWORK_TRAFFIC_GENERIC_SESSION_ID = "session_id";
/**
* The 802.11 service set identifier (ssid) assigned to a wireless session.
*/
public static String NETWORK_TRAFFIC_GENERIC_SSID = "ssid";
/**
* The country from which the packet was sent.
*/
public static String NETWORK_TRAFFIC_GENERIC_SRC_COUNTRY = "src_country";
/**
* The fully qualified host name of the system that transmitted the packet.
* For Web logs, this is the HTTP client.
*/
public static String NETWORK_TRAFFIC_GENERIC_SRC_HOST = "src_host";
/**
* The interface that is listening locally or sending packets remotely.
*/
public static String NETWORK_TRAFFIC_GENERIC_SRC_INT = "src_int";
/**
* The IPv4 address of the packet's source. For Web logs, this is the http
* client.
*/
public static String NETWORK_TRAFFIC_GENERIC_SRC_IP = "src_ip";
/**
* The IPv6 address of the packet's source.
*/
public static String NETWORK_TRAFFIC_GENERIC_SRC_IPV6 = "src_ipv6";
/**
* The (physical) latitude of the packet's source.
*/
public static String NETWORK_TRAFFIC_GENERIC_SRC_LAT = "src_lat";
/**
* The (physical) longitude of the packet's source.
*/
public static String NETWORK_TRAFFIC_GENERIC_SRC_LONG = "src_long";
/**
* The Media Access Control (MAC) address from which a packet was
* transmitted.
*/
public static String NETWORK_TRAFFIC_GENERIC_SRC_MAC = "src_mac";
/**
* The Windows NT domain containing the machines that generated the event.
*/
public static String NETWORK_TRAFFIC_GENERIC_SRC_NT_DOMAIN = "src_nt_domain";
/**
* The Windows NT hostname of the system that generated the event.
*/
public static String NETWORK_TRAFFIC_GENERIC_SRC_NT_HOST = "src_nt_host";
/**
* The network port from which a packet originated.
*/
public static String NETWORK_TRAFFIC_GENERIC_SRC_PORT = "src_port";
/**
* The NATed IPv4 address from which a packet has been sent.
*/
public static String NETWORK_TRAFFIC_GENERIC_SRC_TRANSLATED_IP = "src_translated_ip";
/**
* The NATed network port from which a packet has been sent.
*/
public static String NETWORK_TRAFFIC_GENERIC_SRC_TRANSLATED_PORT = "src_translated_port";
/**
* The application, process, or OS subsystem that generated the event.
*/
public static String NETWORK_TRAFFIC_GENERIC_SYSLOG_ID = "syslog_id";
/**
* The criticality of an event, as recorded by UNIX syslog.
*/
public static String NETWORK_TRAFFIC_GENERIC_SYSLOG_PRIORITY = "syslog_priority";
/**
* The TCP flag(s) specified in the event.
*/
public static String NETWORK_TRAFFIC_GENERIC_TCP_FLAG = "tcp_flag";
/**
* The hex bit that specifies TCP 'type of service'
*
* @see <a href="http://en.wikipedia.org/wiki/Type_of_Service">Type of
* Service</a>
*/
public static String NETWORK_TRAFFIC_GENERIC_TOS = "tos";
/**
* The transport protocol.
*/
public static String NETWORK_TRAFFIC_GENERIC_TRANSPORT = "transport";
/**
* The "time to live" of a packet or datagram.
*/
public static String NETWORK_TRAFFIC_GENERIC_TTL = "ttl";
/**
* The numeric identifier assigned to the virtual local area network (VLAN)
* specified in the record.
*/
public static String NETWORK_TRAFFIC_GENERIC_VLAN_ID = "vlan_id";
/**
* The name assigned to the virtual local area network (VLAN) specified in
* the record.
*/
public static String NETWORK_TRAFFIC_GENERIC_VLAN_NAME = "vlan_name";
// ----------------------------------
// Packet filtering
// ----------------------------------
/**
* The action the filtering device (the dvc_bestmatch field) performed on
* the communication.
*/
public static String PACKET_FILTERING_ACTION = "action";
/**
* The IP port of the packet's destination, such as 22.
*/
public static String PACKET_FILTERING_DEST_PORT = "dest_port";
/**
* The direction the packet is traveling.
*/
public static String PACKET_FILTERING_DIRECTION = "direction";
/**
* The name of the packet filtering device. If your field is named dvc_host,
* dvc_ip, or dvc_nt_host you can alias it as dvc to make it CIM-compliant.
*/
public static String PACKET_FILTERING_DVC = "dvc";
/**
* The rule which took action on the packet, such as 143.
*/
public static String PACKET_FILTERING_RULE = "rule";
/**
* The IP port of the packet's source, such as 34541.
*/
public static String PACKET_FILTERING_SVC_PORT = "svc_port";
// ----------------------------------
// Proxy
// ----------------------------------
/**
* The action taken by the proxy.
*/
public static String PROXY_ACTION = "action";
/**
* The destination of the network traffic (the remote host).
*/
public static String PROXY_DEST = "dest";
/**
* The content-type of the requested HTTP resource.
*/
public static String PROXY_HTTP_CONTENT_TYPE = "http_content_type";
/**
* The HTTP method used to request the resource.
*/
public static String PROXY_HTTP_METHOD = "http_method";
/**
* The HTTP referrer used to request the HTTP resource.
*/
public static String PROXY_HTTP_REFER = "http_refer";
/**
* The HTTP response code.
*/
public static String PROXY_HTTP_RESPONSE = "http_response";
/**
* The user agent used to request the HTTP resource.
*/
public static String PROXY_HTTP_USER_AGENT = "http_user_agent";
/**
* The product name of the vendor technology generating Network Protection
* data, such as IDP, Providentia, and ASA.
*/
public static String PROXY_PRODUCT = "product";
/**
* The source of the network traffic (the client requesting the connection).
*/
public static String PROXY_SRC = "src";
/**
* The HTTP response code indicating the status of the proxy request.
*/
public static String PROXY_STATUS = "status";
/**
* The user that requested the HTTP resource.
*/
public static String PROXY_USER = "user";
/**
* The URL of the requested HTTP resource.
*/
public static String PROXY_URL = "url";
/**
* The vendor technology generating Network Protection data, such as IDP,
* Providentia, and ASA.
*/
public static String PROXY_VENDOR = "vendor";
// ----------------------------------
// System center
// ----------------------------------
/**
* The running application or service on the system (the src field), such as
* explorer.exe or sshd.
*/
public static String SYSTEM_CENTER_APP = "app";
/**
* The amount of disk space available per drive or mount (the mount field)
* on the system (the src field).
*/
public static String SYSTEM_CENTER_FREEMBYTES = "FreeMBytes";
/**
* The version of operating system installed on the host (the src field),
* such as 6.0.1.4 or 2.6.27.30-170.2.82.fc10.x86_64.
*/
public static String SYSTEM_CENTER_KERNEL_RELEASE = "kernel_release";
/**
* Human-readable version of the SystemUptime value.
*/
public static String SYSTEM_CENTER_LABEL = "label";
/**
* The drive or mount reporting available disk space (the FreeMBytes field)
* on the system (the src field).
*/
public static String SYSTEM_CENTER_MOUNT = "mount";
/**
* The name of the operating system installed on the host (the src), such as
* Microsoft Windows Server 2003 or GNU/Linux).
*/